今天所做的努力
都是在为明天积蓄力量

【cisco】Cisco交换机常用配置命令总结

1:配置VLAN                                                          

        理解VLAN: 一个VLAN就是一个交换网,其逻辑上按功能、项目、应用来分而不必考虑用户的物理位置。任何交换口都可以属于某一VLAN, IP包、广播包及组播包均可以发送或广播给在此VLAN内的最终用户。每一个VLAN均可看成是一个逻辑网络,发往另一VLAN的数据包必须由路由器或网桥转发,由于VLAN被看成是一个逻辑网络,其具有自己的网桥管理信息库 (MIB) 并可支持自己的生成树

在Cisco交换机里面有两种配置Vlan的方法:

Switch# configure terminal

Switch(config)# vlan 20

Switch(config-vlan)# name test20

Switch(config-vlan)# end

也可以在enable状态下,进行VLAN配置:

Switch# vlan database

Switch(vlan)# vlan 20 name test20

Switch(vlan)# exit

删除VLAN

当删除一个处于VTP服务器的交换机上删除VLAN时,则此VLAN将在所有相同VTP的交换机上删除。当在透明模式下删除时,只在当前交换机上删除,用vlan database 进入VLAN配置状态,用no vlan vlan-id 来删除。

Switch# vlan database

Switch(vlan)# no vlan 20

Switch(vlan)# exit

将端口分配给一个VLAN

Switch# configure terminal

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# end                                                                             

 2:配置VLAN Trunks

所谓的TRUNK是用来在不同的交换机之间进行连接,以保证在跨越多个交换机上建立的同一个VLAN的成员能够相互通讯,如果是不同台的交换机上相同id的vlan要相互通信,那么可以通过共享的trunk端口就可以实现,如果是不同台不同id的vlan它们之间要相互通信,需要通过第三方的路由来实现.

Switch# configure terminal

Switch(config)# interface fastetherne2/4

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# end

定义trunk允许的VLAN

缺省情况下trunk允许所有的VLAN通过,可以使用 switchport trunk
allowed vlan remove vlan-list 来去掉某一VLAN

Switch(config)# interface fastethernet2/4

Switch(config-if)# switchport trunk allowed vlan remove 2

Switch(config-if)# end                                                                              

3:使用STP实现负载均衡

负载均衡可以使用流量分流到其它平行的trunks上去. 交换机为了避免环路,STP通常是阻断所有端口交换机之间只留一条链路,使用负载均衡后, 可以把不同VLAN的流量分配到不同的trunk上。

可以通过配置STP端口权值STP路径值来实现负载均衡,如果使用STP端口权值来配置那么二条负载均衡的trunk必须联同一交换机上;使用路径值则即可以联相同的交换机与可以联不同的交换机。

使用STP端口权值的负载均衡

当同一台交换机的二个口形成环路时, STP端口权值用来决定那个口是enable的,那个口是阻断的。 可以通过配置端口权值来决定二对trunk各走那些VLAN, 有较高权值的端口(数字较小的)vlan, 将处于转发状态,同一个VLAN在另一个trunk有较低的权值(数字较大)则将处在阻断状态,即同一VLAN只在一个trunk上发送接受。

基于端口权值的负载均衡,trunk1将发送和接收VLAN8-10的数据,trunk2将发送和接收VLAN3-5的数据

interface fastethernet0/1  (进入Trunk1口)

spanning-tree vlan 8 port-priority 10

spanning-tree vlan 9 port-priority 10

spanning-tree vlan 10 port-priority 10

interface fastethernet0/2  (进入Trunk2口)

spanning-tree vlan 3 port-priority 10

spanning-tree vlan 4 port-priority 10

spanning-tree vlan 5 port-priority 10

也可以通过配置配置STP路径值来实现负载均衡,Trunk1走VLAN8-10,Trunk2走VLAN2-4

interface fastethernet 0/1 (进入Trunk1口)

spanning-tree vlan 8 cost 30

spanning-tree vlan 9 cost 30

spanning-tree vlan 10 cost 30

interface fastethernet 0/2 (进入Trunk2口)

spanning-tree vlan 2 cost 30

spanning-tree vlan 3 cost 30

spanning-tree vlan 4 cost 30

4:配置EtherChannel

etherchannel特性在switch到switch、switch到router之间提供冗余的、高速的连接方式,简单说就是将两个设备间多条 fe或ge物理链路捆在一起组成一条设备间逻辑链路,从而达到增加带宽,提供冗余的目的,每个以太通道具有一个port-channel端口号,要捆绑一个以太通道时,会产生一个逻辑port-channel端口,逻辑端口下的配置可影响与之捆绑的物理端口,但物理端口下的配置不能影响逻辑端口的配置

Switch# configure terminal

Switch(config)# interface port-channel 1

Switch(config-if)# ip address 172.16.30.10 255.255.255.0

Switch(config-if)# end

三层物理端口配置

Switch# configure terminal

Switch(config)# interface range fastethernet 3/4 - 5

Switch(config-if)# no switchport

Switch(config-if)# no ip address

Switch(config-if)# channel-group 1 mode desirable

Switch(config-if)# end

二层以太通道配置

Switch# configure terminal

Switch(config)# interface range fastethernet 2/6 - 7

Switch(config-if-range)# channel-group 2 mode desirable

Switch(config-if-range)# end

5:配置以太通道负载均衡

负载均衡关键字表示如下:

src-mac—源MAC地址

dst-mac—目标MAC地址

src-dst-mac—源和目标MAC地址

src-ip—源IP地址

dst-ip—目标IP地址

src-dst-ip—源和目标IP地址 (缺省)

src-port—源第四层端口

dst-port—目标第四层端口

src-dst-port—源和目标第四层端口

Switch(config)# port-channel load-balance src-dst-ip

Switch(config)# end

This example shows how to verify the configuration:

Switch# show etherchannel load-balance

Source XOR Destination IP address

Switch#

本文出自 51CTO.COM技术博客

赞(0)
未经允许不得转载:流觞 » 【cisco】Cisco交换机常用配置命令总结
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址